Network statement does not control what networks are being advertised but instead what interfaces are running EIGRP process Uses protocol number 88 Multicast to 224.0.0.10 (TTL=0) Receiving neighbour unicasts are acknowledged Unequal cost load sharing of up to 16 links EIGRP does not form neighbours over secondary networks/IPs Using the wildcard address 0.0.0.0 in the EIGRP network statement this means that only the interface with that particular IP address will have the EIGRP process enabled. By using all zeros in the wildcard there is no question as to which interfaces are running the EIGRP process. IGRP did not allow the advertisement of the network 0.0.0.0/0 so the ‘ip default-network’ was used as a work around. EIGRP supports both. By default EIGRP uses 50% of the interface bandwidth Hellos are sent using unicast every 60 seconds on links of speed T1 or less and 5 seconds on all other links The ‘hold down’ time internal is 180 seconds on low-speed NBMA networks or 15 seconds on all others To advertise summary and default routes out of interface using EIGRP process

interface se0/0/0 
ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5 #OR 
ip summary-address eigrp 100 31.0.0.0 255.252.0.0 5

The EIGRP ‘leak-map’ feature of the ‘summary-address’ allows the advertisement of specific subnets encompassed by the interface level summary (similar to BGPs unsppress-map feature). Routes in the leak-map router map will be advertised in addition to the summary. If the route-map matches all routes, all subnets of the aggregate will be advertised in addition to the aggregate. This is useful in cases where you want to originate a default route with the interface summary-address but don’t want to stop the advertisements of any subnet. The metric formula (which is also well explained in Cisco’s EIGRP Whitepaper is EIGRP Metric = 256*((K1Bw) + (K2Bw)/(256-Load) + K3Delay)(K5/(Reliability + K4)))

  • K1 = Bandwidth
  • K2 = Load
  • K3 = Delay
  • K4 = Reliability
  • K5 = MTU

To configure EIGRP from the ‘router’ context;

router eigrp
 no auto-summary
 network 0.0.0.0     #advertises the existing and future directly connected networks in the AS
 network 10.1.1.1 0.0.0.0
 network 10.1.1.1 0.0.0.255
 neighbor
 metric wight 0 1 0 0 0 0     #EIGRP only uses BW to calculate metric (tos, k1, k2, k3, k4, k5)
 metric wight 0 0 0 1 0 0     #EIGRP only uses delay to calculate metric
 variance     #enable unequal cost load balance
 timers active-time
 metric maximum-hops      #Changes the default hop-count limit of 100. Values 1-225
 distance
 eigrp stub recieve-olny
 eigrp stub connected leak-map
 redistribute connected route-map
 redistribute static
 default metric
 eigrp stub connected static
 no eigrp log-nieghbor-changes
 eigrp log-neighbor-warning      #log neighbour warning message every no. seconds
 offset-list <0|acl> in       #if the offset list references 0 rather than an ACL it ill apply to ALL routes received
 redistribute eigrp      #redistribution between AS
 traffic-share balanced     #(default)
 traffic-share min across-interfaces     #only use the best metric path even if multiple in routing table
 passive-interface      #disables the interface from sending updates
 no default-information allowed [out|in]

To configure EIGRP from the ‘interface’ context;

interface fa0/0
 ip hello-interval eigrp
 ip hold-time eigrp
 ip summary-address eigrp  10.1.0.0 255.255.252.0     #advertises only summary route out the interface
 ip summary-address eigrp  10.1.0.0 255.255.252.0 leak-map      #summary address as well as entries in leak map. Leak map cant be used on sub-interface, you could use a virtual-template if required
 timers active-time [minutes|disabled]      #changes the SIA timer (default=180 sec)
 ip authentication key-chain eigrp
 ip authentication mode eigrp  md5
 ip bandwidth-percent eirgp       #percentage of the link to be used for exchanging updates
 delay
 no ip split-horizon eigrp      #disables split horizon

To help with troubleshooting;

show ip route eigrp
show ip route eigrp
show ip eigrp topology
show ip eigrp interface detail
show ip protocols
show ip eigrp neighbours
show ip eigrp traffic

debug eigrp packet hello
debug eigrp packet upadte query reply
debug eigrp neighbors